The Diagnostic Server uses .NET libraries to collect data from the machines being monitored. These libraries require at least version 4.5 of the Microsoft .NET framework.
Edit me

To obtain Microsoft .NET 4.5 go to http://www.microsoft.com/en-au/download/details.aspx?id=30653.